Deutsche Post is experiencing label generation errors

Incident Report for Whatnot

Resolved

This incident has been resolved
Posted Jul 31, 2026 - 17:17 PDT

Investigating

We are currently experiencing issues with label generation and actively investigating.
Posted Jul 31, 2026 - 15:34 PDT
This incident affected: Ship.