DHL is experiencing label generation issues

Incident Report for Whatnot

Resolved

This issue has been resolved.
Posted Jul 29, 2026 - 12:38 PDT

Investigating

We are currently experiencing issues with DHL label generation and actively investigating.
Posted Jul 29, 2026 - 12:13 PDT
This incident affected: Ship.