USPS API instability causing intermittent label generation failure

Incident Report for Whatnot

Resolved

We have resolved the issue impacting multiple services and features across Whatnot. Thank you for your patience!
Posted Jun 11, 2026 - 02:13 PDT

Identified

The issue has been identified, we're working with our provider to fix it as soon as possible.
Posted Jun 10, 2026 - 22:28 PDT

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 22:21 PDT

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 22:21 PDT

Investigating

Due to USPS API instability, we are experiencing intermittent label generation failure
Posted Jun 10, 2026 - 22:13 PDT
This incident affected: Ship.