Canada Post labels failing to generate

Incident Report for Whatnot

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 17:34 PDT

Investigating

We are currently experiencing issues with Canada Post label generation and actively investigating.
Posted Jul 28, 2026 - 14:50 PDT
This incident affected: Ship.